I published my site but the old site without my changes still appears

If you made changes in iWeb and but your old site still appears when you visit it in your web browser, try the following steps;


In iWeb go to the File menu and select 'Publish Entire Website'. Then make sure you select 'Publish Entire Website' in iWeb SEO Tool as well in the FTP dialog.



Lastly, make sure you have the correct directory path entered. When using RAGE Web Hosting it should just say;

public_html

Then quit your browser and re-visit your page. It should work now.


If you still see the old website most likely it is caching issue with your web browser. Empty the cache and clear your browser history and try visiting your website again.

  • 2 Users Found This Useful
Was this answer helpful?

Related Articles

I cannot publish my website to RAGE Web Hosting. What should I do?

If you are having trouble publishing your website, please pay close attention to the error...

I get a connection error when using the Test Connection button in iWeb

If you are getting a connection error when trying to publish your website in iWeb OR using the...

iWeb Publishing Error: There was an error communicating with the FTP server. Try again later, or check with your service provider

If you get this error when you try and publish your website with iWeb to your FTP server;...

I don't have the Publish to FTP option in iWeb OR I have iWeb 08. How do I publish?

iWeb 08 and earlier did not come with a Publish to FTP option. If you are using these older...

There was an error communicating with the FTP server. Try again later - iWeb Publishing Fix

If you get the following error in iWeb when you try and publish your website: "There was an...