Viewing Cannot publish Site Changes only

Cannot publish Site Changes only



User: David B. 2 years ago
Every time I select Publish Site Changes from the menu EverWeb always goes ahead and publishes the entire site again. I am only making small changes to a page or two and the pages are not in the navigation menu. I do not have a photo gallery either. Is there anything I can try to do to stop EverWeb from insisting on doing this?
User: EverWeb Support 2 years ago
Hi, David!

Most likely, the issue appears because you have a navigation menu on your website. Since the nav menu is placed on most, if not all the pages, when you add new pages and choose to include them in the navigation menu, the nav menu is updated on all those pages, so they are considered changed and thus get republished next time.

To circumvent this, when adding a new page and choosing a template, please deselect “Include page in navigation menu” option. That way you will be able to only publish the new page, but please note that it will not be included in the navigation menu. If you need it to be included, all the pages with the navigation menu will need to be republished.

You can also do it this way: don’t include new pages in the navigation menu to be able to publish faster while constructing the website, and once you’re done and ready with the whole site and have more time, include them all and republish.

Wayne

-------------------------------
EverWeb Customer Support
Submit Tickets or Learn More

Well done is better than well said.
Benjamin Franklin
User: David B. 2 years ago
I clearly stated that the pages that I am updating are NOT included in the navigation menu. There is no reason why my entire site should need to be updated in order to publish a page that is not in the navigation menu. There definitely seems to be a bug in the EverWeb application.
User: Axel H. 2 years ago
I've the same problems and discussed it with the support the first time in 2015. It's definitely a bug or a bad programming. But it seem that they don't wan't to find a solution to make it work faster with ftp. It's very frustrating...
User: Paul-RAGESW 2 years ago
It definitely should not be publishing the entire site each time.

When you add a page, do all the other pages turn red?

Where you publishing to?

Quote:
I've the same problems and discussed it with the support the first time in 2015. It's definitely a bug or a bad programming. But it seem that they don't wan't to find a solution to make it work faster with ftp. It's very frustrating...


You may be having a different issue. We use EverWeb all the time to publish changes and don't see these issues.

We will be improving uploading to FTP for the next release however.

-------------------------------
Paul
EverWeb Developer

Macworld.com ranks EverWeb as the top choice for Mac users wanting to build a website!
User: Willis C. 2 years ago
I have the same problem. I have a large site that takes about 30 minutes if I publish the entire site. I can go to one page, correct a misspelled word, save, then select "Publish Site Changes" and it republishes the entire site. It didn't do this before the most recent update.
User: Paul-RAGESW 2 years ago
HI Willis,

Sorry for the problems you are experiencing.

Does this happen consistently?

If so, could you show a screen recording so I can reproduce this issue?

You can record your screen using Quicktime which is in your Applications folder. Open Quicktime and select 'New Screen Recording' from the File menu.

Once you are done, your recording will be on your desktop. Please email customer support with the recording.

-------------------------------
Paul
EverWeb Developer

Macworld.com ranks EverWeb as the top choice for Mac users wanting to build a website!
User: Marek P. one year ago
Did anyone find a solution to this issue?
I am having this problem too, I have quite a large site and when I change a page or two and press publish site changes, it publishes the whole site meaning I having to wait over an hour. It's driving me insane!!!
User: EverWeb Support one year ago
Could you please specify which version of EverWeb do you use?

It should work fine with the latest one - EverWeb 2.7.1.

George

-------------------------------
EverWeb Customer Support
Submit Tickets or Learn More

Well done is better than well said.
Benjamin Franklin
User: Shawn K. one year ago
Did anyone find a solution to this issue? to this I have 2.7.1 and still am not able to publish updates only
User: Warren L. 2 months ago
I am also wondering about this problem. I am using V.3.0.6 Build: 2274. My more specific issue is that I will do an update to my site that requires I republish entire site, but then when I make another change within an already published page a short-time later (example: move a graphic slightly) and choose to only Publish Site Changes, EverWeb republishes the entire site a second time. This only usually seems to happen this second time, and after that small changes in one place don't result in unwanted republishing of entire site. But that second republishing is frustrating, and a significant time-sucking vortex. Any help would be appreciated.


Post Reply
You must login or signup to post.