Viewing Cannot publish Site Changes only

Cannot publish Site Changes only



User: David B. 5 months ago
Every time I select Publish Site Changes from the menu EverWeb always goes ahead and publishes the entire site again. I am only making small changes to a page or two and the pages are not in the navigation menu. I do not have a photo gallery either. Is there anything I can try to do to stop EverWeb from insisting on doing this?
User: EverWeb Support 4 months ago
Hi, David!

Most likely, the issue appears because you have a navigation menu on your website. Since the nav menu is placed on most, if not all the pages, when you add new pages and choose to include them in the navigation menu, the nav menu is updated on all those pages, so they are considered changed and thus get republished next time.

To circumvent this, when adding a new page and choosing a template, please deselect “Include page in navigation menu” option. That way you will be able to only publish the new page, but please note that it will not be included in the navigation menu. If you need it to be included, all the pages with the navigation menu will need to be republished.

You can also do it this way: don’t include new pages in the navigation menu to be able to publish faster while constructing the website, and once you’re done and ready with the whole site and have more time, include them all and republish.

Wayne

-------------------------------
EverWeb Customer Support
Submit Tickets or Learn More

Well done is better than well said.
Benjamin Franklin
User: David B. 4 months ago
I clearly stated that the pages that I am updating are NOT included in the navigation menu. There is no reason why my entire site should need to be updated in order to publish a page that is not in the navigation menu. There definitely seems to be a bug in the EverWeb application.
User: Axel H. 3 months ago
I've the same problems and discussed it with the support the first time in 2015. It's definitely a bug or a bad programming. But it seem that they don't wan't to find a solution to make it work faster with ftp. It's very frustrating...
User: Paul-RAGESW 3 months ago
It definitely should not be publishing the entire site each time.

When you add a page, do all the other pages turn red?

Where you publishing to?

Quote:
I've the same problems and discussed it with the support the first time in 2015. It's definitely a bug or a bad programming. But it seem that they don't wan't to find a solution to make it work faster with ftp. It's very frustrating...


You may be having a different issue. We use EverWeb all the time to publish changes and don't see these issues.

We will be improving uploading to FTP for the next release however.

-------------------------------
Paul Levine
EverWeb Developer

Macworld.com ranks EverWeb as the top choice for Mac users wanting to build a website!
User: Willis C. 2 months ago
I have the same problem. I have a large site that takes about 30 minutes if I publish the entire site. I can go to one page, correct a misspelled word, save, then select "Publish Site Changes" and it republishes the entire site. It didn't do this before the most recent update.
User: Paul-RAGESW 2 months ago
HI Willis,

Sorry for the problems you are experiencing.

Does this happen consistently?

If so, could you show a screen recording so I can reproduce this issue?

You can record your screen using Quicktime which is in your Applications folder. Open Quicktime and select 'New Screen Recording' from the File menu.

Once you are done, your recording will be on your desktop. Please email customer support with the recording.

-------------------------------
Paul Levine
EverWeb Developer

Macworld.com ranks EverWeb as the top choice for Mac users wanting to build a website!


Post Reply
You must login or signup to post.